Skip to main content

[JIRA] Created: (SIPSERVLET_SPEC-10) Align with Java EE 6 and Java EE 7

  • From: "binod (JIRA)" < >
  • To:
  • Subject: [JIRA] Created: (SIPSERVLET_SPEC-10) Align with Java EE 6 and Java EE 7
  • Date: Wed, 17 Oct 2012 07:25:12 +0000 (GMT+00:00)
  • Auto-submitted: auto-generated

Align with Java EE 6 and Java EE 7
----------------------------------

                 Key: SIPSERVLET_SPEC-10
                 URL: http://java.net/jira/browse/SIPSERVLET_SPEC-10
             Project: sipservlet-spec
          Issue Type: New Feature
            Reporter: binod


SIP Servlet 1.1 supports Java EE 5. Since then Java EE 6 platform has been 
released. This includes support for many technologies that relevant to SIP 
Servlets.

Some examples are: 
------------------
- Servlet 3.0 enhancements like asynchronous servlets, new annotations (eg: 
InitParam) and pluggability.
- JNDI namespaces for portable JNDI lookups: java:global, java:module, and 
java:app
- Context and Dependency Injection APIs.

Java EE 7 is currently again updating the EE platform and it again updates 
these technologies. 

This feature is to update the SIP Servlet API to align with Java EE 
revisions. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: 
http://java.net/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


[JIRA] Created: (SIPSERVLET_SPEC-10) Align with Java EE 6 and Java EE 7

binod (JIRA) 10/17/2012
 
 
Close
loading
Please Confirm
Close