Skip to main content

Yeah I succeeded gmake publish.

  • From: 유현상 < >
  • To:
  • Subject: Yeah I succeeded gmake publish.
  • Date: Fri, 4 Oct 2013 10:37:57 +0900 (KST)
  • Importance: normal

 
Thank you !
 
I succeeded gmake publish but oscap can't react.
(oscap is command that executing Openscap. it is my project.)
 
So I moved to directory that it can react oscap command.
 
In its directory I can execute oscap but it can't normal execute because 
environment variable.
 
I think that publish can set environmental variable but actually is it can't 
that ?
 
Should I manually set it ? 
 
Thank you.
 
 
ps. Actually I think that I ask a question to openscap engineer but he looks 
tired. Reply does not come immediately.
 
In a nutshell, I trying to install openscap on solaris11.
 
 
 
 
Computer Engineering, Chungnam National University Grade 4. 

Yoo-hyun sang. 
-----Original Message-----
From: "Mike 
Sullivan"&lt; &gt;
 
To: 
"유현상"&lt; &gt;;
 
&lt; &gt;;
 
&lt; &gt;;
 
Cc: 
Sent: 2013-10-04 (금) 02:46:51
Subject: Re: 'is not tagged aslr'


  
    
  
  
    
On 10/03/13 05:33, 유현상 wrote:

    
    
      
        Thanks to Norm jacobs

      
    
    

    btw, I think there's a better alias to use than the commits alias,
    which is really

    just for push notifications. 

 looks
    like it.

    

    

    

    
      
        
        I solved it by your opinion (
          CANONICAL_REPO=... )

      
    
    

    be aware that internally that points to much newer bits for us so

    there may be other issues lurking when you point it at the older

    ones. we certainly aren't testing that.

    

    
      
        
        But I got other errors. 

        
        ERROR userland.action001.5      
           
'/home/yoohs/userland3/components/openscap/build/prototype/i386/usr/bin/oscap'
          is not tagged for aslr

        ERROR userland.action001.5      
           
'/home/yoohs/userland3/components/openscap/build/prototype/i386/usr/lib/openscap/probe_dnscache'
          is not tagged for aslr

        ERROR userland.action001.5      
           
'/home/yoohs/userland3/components/openscap/build/prototype/i386/usr/lib/openscap/probe_environmentvariable'
          is not tagged for aslr

        ................

        
        so I inputed as follows:
          'ASLR_MODE=$(ASLR_ENABLE)' in Makefile both /userland and
          /&lt;project folder&gt;.

        
        but Errors is still displayed.

      
    
    

    those aren't actually trying to make sure aslr is enabled, they want
    to make sure it's been

    tagged  at all. it's an error if SUNW_ASLR is not present:

    

    {mlsulliv:yavin:329} elfdump /usr/bin/ls | grep ASLR

         [39]  SUNW_ASLR       0x2        ENABLE

    

    if it's there but not enabled you'd just get a warning. that's part
    of our extensions in:

    

    tools/python/pkglint/userland.py

    

    the build forces it to be at minimum disabled, but probably through
    linker variables that

    you might not have if you're building on s11 (not sure when/if they
    got ported back),

    which is probably the problem.

    

    the simplest thing to do might be to disable pkglint for now

    

        gmake PKGLINT=/bin/true publish

    

    

        Mike

    

    
      
        
        have you any idea ?

        
        Thank you:D

        
        Computer Engineering, Chungnam National University Grade 4. 

        

        Yoo-hyun sang.
      
        
      
    
    

  







'is not tagged aslr'

유현상 10/03/2013

Re: 'is not tagged aslr'

Mike Sullivan 10/03/2013

Message not available

Yeah I succeeded gmake publish.

유현상 10/04/2013

Re: Yeah I succeeded gmake publish.

Mike Sullivan 10/04/2013
 
 
Close
loading
Please Confirm
Close