Skip to main content

Element wait is timing out after 30 seconds even if the timeout is set to 90 seconds

  3 posts   Feedicon  
Replies: 2 - Last Post: June 18, 2013 08:39
by: dublinario
showing 1 - 3 of 3
Posted: November 06, 2012 15:24 by costini

I'm having some problems with the way the timeout is handled in Thucydides and I need some help to understand what I'm doing wrong.

1. I run the project with the following parameters:

(I added both implicitlywait & implicitywait just to be sure that the typo from documentation is not also in code)

2. in my test I set the the driver to timeout after 90 seconds:
getDriver().manage().timeouts().implicitlyWait(90, TimeUnit.SECONDS);

With all these settings the error that I receive is: Timed out after 30 seconds waiting for net.thucydides.core.pages.WebElementFacade$3@16443d7f

Any idea what's wrong? Any hint would be very helpful.

Posted: November 21, 2012 00:10 by johnsmart
I think this is due to a bug with the "webdriver.timeouts.implicitlywait" property - should be fixed in the next release.
Posted: June 18, 2013 08:39 by dublinario
Hi John,

Is there any update on this issue since you last posted on this thread? I'm using version 0.9.125 of Thucydides, and encountering the exact same symptoms as the original poster. I cannot seem to influence the hard 30 second threshold with any command-line parameter, or explicit calls to 'getDriver().manage().timeouts().implicitlyWait()'

Replies: 2 - Last Post: June 18, 2013 08:39
by: dublinario
Please Confirm