RE: VisualVM 1.3.7 Released

  • From: "KARR, DAVID" <dk068x@...>
  • To: "users@..." <users@...>
  • Subject: RE: VisualVM 1.3.7 Released
  • Date: Thu, 23 Jan 2014 17:38:28 +0000
  • Accept-language: en-US

> -----Original Message-----
> From: KARR, DAVID
> Sent: Thursday, January 23, 2014 9:01 AM
> To: users@...
> Subject: RE: VisualVM 1.3.7 Released
> 
> > -----Original Message-----
> > From: Jiri Sedlacek [mailto:jiri.sedlacek@...]
> > Sent: Thursday, January 23, 2014 4:33 AM
> > To: KARR, DAVID
> > Cc: users@...
> > Subject: Re: VisualVM 1.3.7 Released
> >
> > On 1/23/2014 12:42 AM, KARR, DAVID wrote:
> > >> -----Original Message-----
> > >> From: Jiri Sedlacek [mailto:jiri.sedlacek@...]
> > >> Sent: Wednesday, January 22, 2014 10:39 AM
> > >> To: announce@...
> > >> Cc: users@...
> > >> Subject: VisualVM 1.3.7 Released
> > >>
> > >> We would like to announce the availability of VisualVM 1.3.7.
> > >>
> > >> VisualVM 1.3.7 introduces these enhancements:
> > >>    * HeapWalker displays logical values of fields and preview for UI
> > >> components
> > >>    * CPU Hot Spots views provide total times
> > >>    * Threads profiling now tracks Park state
> > >>    * Added support for JMX connections which don't require SSL
> > >>    * Removed calibration on first VisualVM startup, target JVMs are
> > calibrated
> > >> only when needed
> > >>    * Built on NetBeans Platform & profiler 7.4
> > >
> > > I've been using 1.3.6 for a while.  I had several plugins installed.
> > >
> > > When I ran 1.3.7, the first thing I did was install some of the plugins.
> > When I restarted, it said I had no plugins installed.  I tried it again,
> only
> > installing one plugin and restarting.  No plugin.
> > >
> > > Could this be a local system configuration problem?
> > >
> >
> > Hi David,
> >
> > we haven't seen such problems when testing 1.3.7 before release, looks 
> > like
> a
> > setup issue on your side.
> >
> > Were the plugins fully downloaded, did the VisualVM restart after their
> > installation?
> >
> > Check the VisualVM logfile (Help | About | Logfile) for any problems and
> also
> > verify that the
> > original 1.3.6 and 1.3.7 don't share the same user/cache directory (Help |
> > About | Details).
> >
> > Please let me know the result.
> 
> There's something seriously weird going on here.
> 
> I can confirm that 1.3.6 and 1.3.7 are independent.
> 
> This morning, I tried to reinstall just the mbeans plugin, which reported a
> failure.  The log showed odd errors, like timing out attempting to connect 
> to
> my own IP address.  I then restarted and tried to install it again.  This
> time it worked.  I didn't do anything differently.
> 
> I also note that the main window was showing "Computing Description" for
> quite a long time before finally showing the local process list.
> 
> At this point I started a process I wanted to monitor (WebLogic), and I saw
> some very odd things in the WebLogic log, like this:
> ----------------------
> WARNING: RMI TCP Accept-0: accept loop for
> ServerSocket[addr=0.0.0.0/0.0.0.0,port=0,localport=56298] throws
> 
> java.io.IOException: The server sockets created using the
> LocalRMIServerSocketFactory only accept connections from clients running on
> the host where the RMI remote objects have been exported.
> ----------------------
> 
> When I tried to open the MBeans tab on the connected process in VisualVM, it
> said "Data not available because JMX connection to the JMX agent could not 
> be
> established".
> 
> I then tried this same set of steps with VisualVM 1.3.6, and it worked
> perfectly fine.  Note that I don't have as many plugins installed in the
> 1.3.7 instance as in the 1.3.6 instance.

I also tried simply stopping the 1.3.7 instance and started 1.3.6, while the 
WebLogic process was still running (the one that reported those 
IOExceptions).  It connected quickly and was able to show my mbeans.

At this point I made sure that I had the same plugins installed in 1.3.7 and 
retested.  Same.




VisualVM 1.3.7 Released

Jiri Sedlacek 01/22/2014

RE: VisualVM 1.3.7 Released

KARR, DAVID 01/22/2014

Re: VisualVM 1.3.7 Released

Jiri Sedlacek 01/23/2014

Re: VisualVM 1.3.7 Released

Jess Holle 01/23/2014

Re: VisualVM 1.3.7 Released

Kirk Pepperdine 01/23/2014

RE: VisualVM 1.3.7 Released

KARR, DAVID 01/23/2014

Re: VisualVM 1.3.7 Released

Jiri Sedlacek 01/23/2014

RE: VisualVM 1.3.7 Released

KARR, DAVID 01/23/2014

Re: VisualVM 1.3.7 Released

Jiri Sedlacek 01/24/2014

RE: VisualVM 1.3.7 Released

KARR, DAVID 01/23/2014
Terms of Use; Privacy Policy; Copyright ©2013-2015 (revision 20150226.965aeb8)
 
 
Close
loading
Please Confirm
Close