RE: VisualVM on new laptop can't make local jmx connections

  • From: "KARR, DAVID" <dk068x@...>
  • To: "users@..." <users@...>
  • Subject: RE: VisualVM on new laptop can't make local jmx connections
  • Date: Tue, 6 May 2014 15:33:07 +0000
  • Accept-language: en-US

> -----Original Message-----
> From: Tomas Hurka [mailto:tomas.hurka@...]
> Sent: Tuesday, May 06, 2014 2:20 AM
> To: users@...
> Subject: Re: VisualVM on new laptop can't make local jmx connections
> 
> Hi David,
> 
> On 5 May 2014, at 17:09, KARR, DAVID <dk068x@...> wrote:
> >> On 5 May 2014, at 16:01, KARR, DAVID <dk068x@...> wrote:
> >> [..]
> >>>> So VisualVM is unable to set up JMX connection to both Eclipse and
> >>>> WebLogic. Am I right? Please post VisualVM's messages.log file and
> >>>> application snapshot of Eclipse processes.
> >>>>
> >>>
> >>> What exactly is "application snapshot of Eclipse processes"?
> >>
> >> See https://visualvm.java.net/snapshots.html section "Application
> >> Snapshots"
> >
> > Ok.
> > <application-1399302106393.apps><messages.log>
> 
> thanks for the info. It shows that your problem is caused by running
> VisualVM on 32bit JDK (C:\Program Files (x86)\Java\jdk1.8.0_05\) and
> Eclipse on 64bit JDK (C:\eclipse\Java\jdk1.8.0_05). In this situation
> VisualVM (via Attach API) is not able to enable JMX connection to
> applications running on 64bit JVM. The solution is to run VisualVM on
> 64bit JDK or enable local JMX monitoring via setting the following system
> property when you started the Eclipse application.
> 
> com.sun.management.jmxremote

It appears that just setting this property on the target JVM allows the local 
JMX connection to succeed.

However, this is only working from the separate VisualVM 1.3.7 distribution.  
When I run "jvisualvm" from any JDK, even the one running Eclipse or any 
other Java process, then the only JVM that shows up in the local list is just 
"VisualVM".  This isn't an issue with getting the JMX connection, it's 
completely unable to see the process in the first place.

I seem to remember something in the VisualVM docs that referred to this being 
an "access permission" issue, but I don't see how that can be controlled.  I 
tried running the "jvisualvm" process both as an administrator and not.



RE: VisualVM on new laptop can't make local jmx connections

(continued)

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/04/2014

Re: VisualVM on new laptop can't make local jmx connections

Kirk Pepperdine 05/04/2014

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/04/2014

Re: VisualVM on new laptop can't make local jmx connections

Tomas Hurka 05/05/2014

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/05/2014

Re: VisualVM on new laptop can't make local jmx connections

Tomas Hurka 05/05/2014

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/05/2014

Re: VisualVM on new laptop can't make local jmx connections

Tomas Hurka 05/06/2014

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/06/2014

Re: VisualVM on new laptop can't make local jmx connections

Tomas Hurka 05/06/2014

RE: VisualVM on new laptop can't make local jmx connections

KARR, DAVID 05/06/2014

Re: VisualVM on new laptop can't make local jmx connections

Tomas Hurka 05/06/2014
Terms of Use; Privacy Policy; Copyright ©2013-2015 (revision 20150626.29986a4)
 
 
Close
loading
Please Confirm
Close